[opensource-dev] Review Request: Make viewer-autobuild work under Visual Studio 2005 Express Edition.

Nicky Perian nickyperian at yahoo.com
Sun Feb 6 11:17:14 PST 2011


Later today Ill bring up in IDE and see it the same errors arise. idk what is 
happening but if 2 that we know have them of then we need to try and correct.



________________________________
From: Twisted Laws <twisted_laws at hotmail.com>
To: Oz Linden <oz at lindenlab.com>; SLDEV <opensource-dev at lists.secondlife.com>
Sent: Sun, February 6, 2011 1:07:27 PM
Subject: Re: [opensource-dev] Review Request: Make viewer-autobuild work under 
Visual Studio 2005 Express Edition.

 Ok, i found i can get much further compiling in the IDE and this is all i end 
up with now.  Note that the issue with winres.h is one i always have had with 
and easy change of defining IDC_STATIC and including winresrc.h instead.
 
Twisted
 
Warning 1 warning LNK4099: PDB 'vc80.pdb' was not found with 
'..\packages\lib\release\exception_handler.lib' or at 
'C:\dev\hgbuilds\viewer-autobuildvs8\build-vc80\sharedlibs\RelWithDebInfo\vc80.pdb';
 linking object as if no debug info exception_handler.lib 
Warning 2 warning LNK4099: PDB 'vc80.pdb' was not found with 
'..\packages\lib\release\crash_generation_client.lib' or at 
'C:\dev\hgbuilds\viewer-autobuildvs8\build-vc80\sharedlibs\RelWithDebInfo\vc80.pdb';
 linking object as if no debug info crash_generation_client.lib 
Warning 3 warning LNK4099: PDB 'vc80.pdb' was not found with 
'..\packages\lib\release\common.lib' or at 
'C:\dev\hgbuilds\viewer-autobuildvs8\build-vc80\sharedlibs\RelWithDebInfo\vc80.pdb';
 linking object as if no debug info common.lib 
Error 4 error PRJ0019: A tool returned an error code from "Generating 
PROJECT_llmessage_TEST_lltemplatemessagedispatcher_ok.txt" llmessage_tests 
Error 5 error PRJ0019: A tool returned an error code from "Generating 
PROJECT_llupdaterservice_TEST_llupdaterservice_ok.txt" llupdaterservice_tests 
Error 6 error PRJ0019: A tool returned an error code from "Performing 
viewer_manifest copy" copy_w_viewer_manifest 
Warning 7 warning LNK4221: no public symbols found; archive member will be 
inaccessible llfunctorregistry.obj 
Error 8 fatal error RC1015: cannot open include file 
'winres.h'. c:\dev\hgbuilds\viewer-autobuildvs8\indra\newview\res\viewerRes.rc 10 

Error 9 error PRJ0019: A tool returned an error code from "Generating 
RelWithDebInfo/touched.bat" package 

 
________________________________
 From: twisted_laws at hotmail.com
To: oz at lindenlab.com; opensource-dev at lists.secondlife.com
Date: Sun, 6 Feb 2011 12:56:55 -0500
Subject: Re: [opensource-dev] Review Request: Make viewer-autobuild work under 
Visual Studio 2005 Express Edition.

 Ok, i'm an idiot and can't follow instructions....   So i  reread Oz's msg and 
found i was using the wrong config and redid it with 

autobuild configure -c VCexpressRelWithDebInfo
 
Then that part worked ok.
 
If i then just used "autobuild build" it had the same fmod error as before.
 
So i tried autobuild build -c VCexpressRelWithDebInfo --verbose  and things went 
further but as someone else reported then i got 100's of errors about winsock2.h 
not being found.   Why does it continue to try to build everything after it gets 
so many errors?  

 
Build complete: 12 Projects succeeded, 113 Projects failed, 2 Projects skipped
 
 

_______________________________________________ Policies and (un)subscribe 
information available here: http://wiki.secondlife.com/wiki/OpenSource-Dev 
Please read the policies before posting to keep unmoderated posting privileges 



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/opensource-dev/attachments/20110206/3d52c002/attachment-0001.htm 


More information about the opensource-dev mailing list