[opensource-dev] Linux build error: missing binary operator before token "(" (was: Hacking up to Visual Studio 2010 ...)

Boroondas Gupte sllists at boroon.dasgupta.ch
Fri Feb 18 05:45:05 PST 2011


On 02/18/2011 01:56 AM, Oz Linden (Scott Lawrence) wrote:
> [...]
>
> Then check out:
>
>     https://bitbucket.org/oz_linden/viewer-autobuild2010
>
> cd into the top level of that directory, and run:
>
>     autobuild configure -c OpenSourceRelWithDebInfo
>
>     autobuild configure -c OpenSourceRelWithDebInfo
>
> and let me know if it works (and if not, see if you can figure out why
> not).  On our build farm, I'm getting an error:
>
> _[19:13:30]:_ //LogScan//_(1s)_
> _[19:13:30]:_ /[LogScan] / from /usr/include/c++/4.1.3/cmath:53,
> _[19:13:30]:_ /[LogScan] / from
> /var/opt/teamcity/checkout/L-oz_viewer-autobuild2010/latest/indra/llcommon/linden_common.h:48,
> _[19:13:30]:_ /[LogScan] / from
> /var/opt/teamcity/checkout/L-oz_viewer-autobuild2010/latest/indra/newview/tests/lldateutil_test.cpp:26:
> _[19:13:30]:_ /[LogScan] //usr/include/bits/huge_val.h:28:18: error:
> missing binary operator before token "("
> _[19:13:30]:_ /[LogScan] //usr/include/bits/huge_val.h:30:20: error:
> missing binary operator before token "("
With "build" in the second command instead of "configure", I'm getting
the same error, though not just for /usr/include/bits/huge_val.h but
many more system headers, too.

Boroondas

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/opensource-dev/attachments/20110218/f3abab59/attachment-0001.htm 


More information about the opensource-dev mailing list