[opensource-dev] Is 'STANDALONE' confusing?
ima.mechanique at blueyonder.co.uk
Mon Feb 21 08:38:11 PST 2011
> On 02/21/2011 03:28 PM, Oz Linden (Scott Lawrence) wrote:
> > If we are going to change it, the replacement term should, in addition
> > to being more accurately descriptive of what it does, be an affirmative
> > term - don't suggest any 'NO_*" replacements.
> Would it be acceptable to invert the setting's semantic in order to
> avoid a negation? I.e., STANDALONE=OFF would become NEW_SETTING=ON and
> vice versa. That'd allow for easy-to-understand names like
> USE_PREBUILD_LIBS or DOWNLOAD_NEEDED_DEPENDENCIES.
> Off course, the default value should be inverted together with the
> setting's semantic, such that the default behavior does not change.
Agree with changing the semantics.
I'd prefer something shorter and somewhat more consistent with existing
settings, like "LL_LIBS_DOWNLOAD" or "LL_LIBS_FETCH"
However, it's not a strong preference.
> Policies and (un)subscribe information available here:
> Please read the policies before posting to keep unmoderated posting privileges
More information about the opensource-dev