[opensource-dev] Snowglobe 2.0 sync with Viewer 2.0

Dzonatas Sol dzonatas at gmail.com
Thu Apr 8 14:40:53 PDT 2010


I just tried it again, so now I can confirm there is no difference 
between a compilation with G++-4.1 or G++-4.4 in relation to this error.

Linking CXX executable secondlife-bin
/usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/libSM.so: undefined 
reference to `uuid_generate at UUID_1.0'
/usr/lib/gcc/i486-linux-gnu/4.1.3/../../../../lib/libSM.so: undefined 
reference to `uuid_unparse_lower at UUID_1.0'
collect2: ld returned 1 exit status

Maybe something special about libSM that it needs a specific version of 
libuuid, or maybe as Lance suggested, it doesn't use the the LL supplied 
versus the system version.

Lance Corrimal wrote:
> I'm having the same problem on opensuse 11.2.
> until recently it built fine... after some change introduced a script 
> which replaces the prebuilt libs with the systemwide installed ones, 
> it stopped building with exactly that error.
>
> why do i even have to have the build script download the prebuilt libs 
> when they dont get used?
>
>
> bye,
> LC
>
>
> Am Donnerstag 08 April 2010 schrieb Dzonatas Sol:
>   
>> I got it to compile to the secondlife-bin link stage, but then I
>> got a link error:
>>
>> /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libSM.so:
>> undefined reference to `uuid_generate at UUID_1.0'
>> /usr/lib/gcc/i486-linux-gnu/4.4.3/../../../../lib/libSM.so:
>> undefined reference to `uuid_unparse_lower at UUID_1.0'
>> collect2: ld returned 1 exit status
>>
>> It does try to link against libuuid, with this link order:
>>
>>  -lndofdev -lXinerama -lboost_program_options-gcc41-mt
>> -lboost_regex-gcc41-mt -lgobject-2.0 -lglib-2.0 -lGLU -lGL -lSM
>> -lICE -lX11 -lXext -lGLU -lGL -lSM -lICE -lX11 -lXext -lSDL
>> -latk-1.0 -lgdk-x11-2.0 -lgdk_pixbuf-2.0 -lXinerama -lglib-2.0
>> -lgmodule-2.0 -lgobject-2.0 -lgthread-2.0 -lgtk-x11-2.0
>> -lpango-1.0 -lpangoft2-1.0 -lpangox-1.0 -lpangoxft-1.0
>> -lxmlrpc-epi -lELFIO
>> ../viewer_components/login/liblllogin.a ../llmessage/libllmessage.a
>> -lcurl -lcares -lssl -lcrypto -lxmlrpc-epi
>> ../llrender/libllrender.a ../llimage/libllimage.a
>> ../llimagej2coj/libllimagej2coj.a -lopenjpeg -ljpeg -lpng12
>> -lfreetype -lGLU -lGL -lSM -lICE -lX11 -lXext -lSDL
>> ../llxml/libllxml.a ../llvfs/libllvfs.a ../llmath/libllmath.a
>> ../llcommon/libllcommon.so -laprutil-1 -ldb-4.2 -luuid -ldb-4.2
>> -luuid -lrt -lapr-1 -lboost_program_options-gcc41-mt
>> -lboost_regex-gcc41-mt -lz -lexpat
>>
>>
>> This might be a recent change in compiler which forces one to use
>> GCC 4.1...  and I didn't see this one in jira.
>>
>> I'll work this issue out more to see if it is merely a
>> GCC4.4/GCC4.1 difference.
>>
>>
>> _______________________________________________
>> Policies and (un)subscribe information available here:
>> http://wiki.secondlife.com/wiki/OpenSource-Dev
>> Please read the policies before posting to keep unmoderated posting
>> privileges
>>     
>
> _______________________________________________
> Policies and (un)subscribe information available here:
> http://wiki.secondlife.com/wiki/OpenSource-Dev
> Please read the policies before posting to keep unmoderated posting privileges
>
>   



More information about the opensource-dev mailing list