[opensource-dev] texture problem on avatars

Chang Liu liu.chang at gmail.com
Thu Apr 29 15:07:56 PDT 2010


In 1.23.4 Second Life viewer, when connecting to 0.6.9 OpenSim server, we
saw what's shown in the attached pictures.  These mosaics are red and green
instead of black and white in the original message that I sent out a week
ago.  Are these red and green mosaic also caused alpha channel problems?
 They look slightly different in shape and also of course different in
color.

These problems don't show up right away.  It usually show up after a few
minutes of play.  If one opens up the edit appearance window, and then close
it, all of these problems will go away.  Any guess of what's behind this?

Many thanks.

~Chang


On Thu, Apr 22, 2010 at 11:54 AM, Nicky Perian <nickyperian at yahoo.com>wrote:

> On the earlier versions of opensim  there was a bug that affected the way
> images with transparent channels were uploaded. For lack of a better
> description it appeared the transparent part was placed in front of the
> image instead of behind. I test on opensim server 0.6.9 on my local machine
> and that appears to be corrected. So, they may be a mix of issues that you
> are seeing. If using the older than 0.6.9 opensim server.
>
>
> ------------------------------
> *From:* Jacek Antonelli <jacek.antonelli at gmail.com>
> *To:* Chang Liu <liu.chang at gmail.com>
> *Cc:* opensource-dev at lists.secondlife.com
> *Sent:* Wed, April 21, 2010 6:41:39 PM
>
> *Subject:* Re: [opensource-dev] texture problem on avatars
>
> We have been seeing exactly the same thing with Imprudence 1.3
> recently (which is based on SL 1.23 with some Snowglobe mixed in),
> also when connected to OpenSim. I'm not sure why it only seems to
> occur on OpenSim, but I can confirm that it's related to the change in
> texture channels, as Nyx said. We'll be working on this issue soon; if
> we find a fix, we'll be sure to share it.
>
> - Jacek
>
> On Wed, Apr 21, 2010 at 9:12 AM, Chang Liu <liu.chang at gmail.com> wrote:
> > Hi, Nyx,
> >
> > We were using viewer 1.23.4.  Interestingly, the official 1.23.4 viewer
> > binary release does not have this problem.  But after we compiled and
> > packaged the 1.23.4 source release, we saw this problem.  We didn't mix
> 2.0
> > at all.
> > Since this is related to compiling and packaging, could it be a
> particular
> > library that's referred to in the code?
> > Thanks!
> >
> > ~Chang
> >
> >
> > On Tue, Apr 20, 2010 at 5:42 PM, Nyx Linden <nyx at lindenlab.com> wrote:
> >>
> >>  What version of the viewer are you using? Viewer-1.23 redefined the
> >> fourth channel of baked textures to be "alpha mask" instead of "bump
> map".
> >> If you load old baked textures that generated a fourth channel intending
> it
> >> to be a bump map, and use it as a baked texture for a 1.23+ viewer, the
> >> viewer will incorrectly interpret the fourth channel as an alpha mask,
> >> resulting in images like you included in your email.
> >>
> >> Were the avatars on the sim a mix of 2.0 and 1.22 (or previous) versions
> >> by any chance?
> >>
> >> -Nyx
> >>
> >>
> >> Chang Liu wrote:
> >>>
> >>> Hi, all, when we connect a modified version of Second Life Client
> Viewer
> >>> to OpenSim, we notice that from time to time, textures on avatars may
> turn
> >>> into mosaic and hollow like what's shown in the attached screenshots.
>  Has
> >>> anyone seen this before?  Any clues as to what may have gone wrong?
> Many
> >>> thanks.
> >>>
> >>> ~Chang
> _______________________________________________
> Policies and (un)subscribe information available here:
> http://wiki.secondlife.com/wiki/OpenSource-Dev
> Please read the policies before posting to keep unmoderated posting
> privileges
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/opensource-dev/attachments/20100429/53bba968/attachment-0001.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen shot 2010-04-29 at 5.57.20 PM.png
Type: image/png
Size: 465032 bytes
Desc: not available
Url : http://lists.secondlife.com/pipermail/opensource-dev/attachments/20100429/53bba968/attachment-0003.png 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen shot 2010-04-29 at 5.56.43 PM.png
Type: image/png
Size: 460977 bytes
Desc: not available
Url : http://lists.secondlife.com/pipermail/opensource-dev/attachments/20100429/53bba968/attachment-0004.png 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Screen shot 2010-04-29 at 5.56.24 PM.png
Type: image/png
Size: 363755 bytes
Desc: not available
Url : http://lists.secondlife.com/pipermail/opensource-dev/attachments/20100429/53bba968/attachment-0005.png 


More information about the opensource-dev mailing list