[opensource-dev] STORM-1023 (was OPEN-4) : fmod

WolfPup Lowenhar wolfpup67 at earthlink.net
Sat Feb 26 07:30:53 PST 2011


After creating a local repository like the one Nicky has and running
autobuild configure -c VC10msbuildRelWithDebInfo I get an error in FindFMOD
stating cannot find FMOD and the configure fails.

 

From: opensource-dev-bounces at lists.secondlife.com
[mailto:opensource-dev-bounces at lists.secondlife.com] On Behalf Of WolfPup
Lowenhar
Sent: Saturday, February 26, 2011 8:58 AM
To: OpenSource Mailing List
Subject: Re: [opensource-dev] STORM-1023 (was OPEN-4) : fmod

 

See my comment here:

https://jira.secondlife.com/browse/STORM-1023?focusedCommentId=244786
<https://jira.secondlife.com/browse/STORM-1023?focusedCommentId=244786&page=
com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-244
786>
&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comme
nt-244786

 

This might be a better solution as then the files could also be renamed to
properly match what cmake is looking for plus when autobuild sets up the
build tree the needed files would be placed automatically with no problems
during the configuration process as they would be resident in the OS
developers install.cache directory with the rest of the needed packaged for
developers that DL libs form LL. And as I do not realy know the how to set
up one of these lib systems assistance would be greatly welcomed. 

 

From: opensource-dev-bounces at lists.secondlife.com
[mailto:opensource-dev-bounces at lists.secondlife.com] On Behalf Of Nicky
Perian
Sent: Friday, February 25, 2011 4:01 PM
To: Philippe (Merov) Bossut
Cc: opensource-dev at lists.secondlife.com
Subject: Re: [opensource-dev] STORM-1023 (was OPEN-4) : fmod

 

I am using oz's viewer-autobuild2010 with my mod's for VS2010 and your
changes at the tip.

 

https://bitbucket.org/NickyP/viewer-autobuild2010-wip this plus your changes
at tip.

 

I would not be able to test otherwise.

 

Nicky

 

  _____  

From: Philippe (Merov) Bossut <merov at lindenlab.com>
To: Nicky Perian <nickyperian at yahoo.com>
Cc: opensource-dev at lists.secondlife.com
Sent: Fri, February 25, 2011 12:33:27 PM
Subject: Re: [opensource-dev] STORM-1023 (was OPEN-4) : fmod

Hi Nicky,

On Fri, Feb 25, 2011 at 8:03 AM, Nicky Perian <nickyperian at yahoo.com> wrote:

I have -DFMOD:BOOL=ON on configure cl

and

DFMOD=TRUE in autobuild.xml

Attempt is made to build with fmod but, the headers and libraries still need
to be manually copied.

Was that the intent?


Nope. Looks like either FindFMOD couldn't locate the files or it wasn't
invoked at all.

Could you tell me which autobuild configure arguments you use?

Again, thanks for the test. Looks like I've more coding to do.

Cheers,
- Merov 

 

  _____  

No virus found in this message.
Checked by AVG - www.avg.com
Version: 10.0.1204 / Virus Database: 1435/3468 - Release Date: 02/25/11

  _____  

No virus found in this message.
Checked by AVG - www.avg.com
Version: 10.0.1204 / Virus Database: 1435/3469 - Release Date: 02/26/11

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.secondlife.com/pipermail/opensource-dev/attachments/20110226/aecd68ec/attachment-0001.htm 


More information about the opensource-dev mailing list