[sldev] Something is up with crash rate

Tayra Dagostino tayra.dagostino at gmail.com
Wed Aug 5 03:21:30 PDT 2009


On Tue, 04 Aug 2009 13:30:48 -0700
Rob Lanphier <robla at lindenlab.com> wrote:


> Crash rates per 100 hours:
> 
> Snowglobe Release 1.0.2.2451       12.26
> Snowglobe Release 1.0.3.2537       11.25
> Snowglobe Release 1.1.2.2584       13.76
> Snowglobe Test Build 1.1.0.2558     5.82
> Snowglobe Test Build 1.1.0.2565     9.57
> 
> (lower is better)

I cannot diagnose correctly why i crash, neither how crashlogger can
report the reason, i can only say what i see just before crash...

I crash very few time, what i see is: 
- all prims are grey, no texture rendering
- HUD texture on avatar body (and other see too, not so good private IM
visible on body)
- other see me as shadow, skin is transparent
- i have UI problem few time before crash (background of chat windows,
inventory e map transparent)

very few time if a teleport take a lot of time i'm disconnected by
viewer, but i don't think this is a "crash"

> Anyway, this is partial data, and I'm still sifting through the raw
> data.  We'll have to see if the ratios hold, and if they do, figure
> out how we're going to fix our new batch of problems.  Hopefully,
> there's something wrong with how I'm crunching the numbers rather
> than with Snowglobe 1.1.

If i'm right more than 66% of lines pasted by you are related to cache
(fetch, purging and so)


there is a way to let crashlogger work with gdb/other to better
diagnose why program exit? (maybe a new crashlogger, not lunched after
viewer but crashlogger run viewer and continue to check all thread and
calls)


More information about the SLDev mailing list